Dodge RamCharger Central banner
1 - 9 of 9 Posts

·
Registered
Joined
·
725 Posts
Discussion Starter · #1 ·
I have an 1989 Ramcharger, stock everything....I get this weird thumping noise when I step on the accelorator quickly, for example... if i'm coming to a stop light and its red but changes i resume to the speed limit and get the thumping type noise, but when I let off the accell. for the right speed it sounds fine....Also, i've been noticing a loss of power in my car, it dosen't accelorate as well as it use to.
-Anyone know what I should do???
 

·
Registered
Joined
·
725 Posts
Discussion Starter · #4 ·
lol, i'll check for peds......but for real i'll check the mounts.....any other ideas.....
 

·
Registered
Joined
·
725 Posts
Discussion Starter · #5 ·
okay the motor mounts seem fine, but what I did find is that i'm missing a bushing(?) mount, the soft rubbery thing(i dont know what to call it)....the three that are on there look worn out, and the other is missing....could that be the problem?
 

·
Registered
Joined
·
1,183 Posts
My guess would be what Chump said but failing in that, I would check for a loose shock or body mount doughnut. After that, try to get someone or more than one to rock the vehicle as hard as they can while you are under it (not on a jack please - engine off - brake on - be safe). See if you can make the sound happen without the engine running.

Good luck.

Mac
 

·
Moderator
Joined
·
7,995 Posts
nmetankrc said:
okay the motor mounts seem fine, but what I did find is that i'm missing a bushing(?) mount, the soft rubbery thing(i dont know what to call it)....the three that are on there look worn out, and the other is missing....could that be the problem?
If these are under your transfer case than that could be your noise. Autozone, NAPA or Carquest will have them and they are sometimes called transmission mounts even though they go under the transfer case.:) They look like this...



 

·
Registered
Joined
·
725 Posts
Discussion Starter · #8 ·
Chump you da man, thanks a lot guys for helping out. i will have this fixed very soon to let you know what's going on. Wednesday(28th) i will see if my friend is going to replace my front passenger wheelbase U-joint, and i'll see if he can fix that up to. Is there anything I should know about replacing those trans mounts???
 

·
Registered
Joined
·
1,640 Posts
yeah dont lose the bushings that goinside of them, and follow torque specs cause you'll smash them if you put to much muscle on the bolts.
 
1 - 9 of 9 Posts
Top