Dodge RamCharger Central banner
1 - 7 of 7 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter · #1 · (Edited)
need wiring harness that I believe runs from near passenger headlite
to the horn(s)

1980
w150
dodge truck

thanx dave denning
 

·
Registered
Joined
·
123 Posts
Discussion Starter · #3 ·
I need to post picture
I did not realize I had some connectors hanging from horn

I only have one horn,...found green wire coming out of wiring harness of driver side near radiator, that had been clipped

it looked like the green wire on horn harness
the horn harness has two blade type slide on connectors at horn

one was on horn, the other looked like it would slip onto second horn if there was dual horns, then a green wire coming from those two slide on connectors had been cut
I figured it must have went to the wire coming out of headlight wiring harness at one time, I joined those, but no horn sound, wondering if the square cube horn relay is bad or if horn is bad, etc etc....
I have a TSM and have looked at it. looks like this is possibly what has happened.
 

·
Registered
Joined
·
123 Posts
Discussion Starter · #4 ·
here is a photo of what I have...

WHEN I GOT THE TRUCK,....the horn had one blade connector on it, and one blade connector dangling, and one green wire coming from them that had been cut........and no evidence of there ever being dual horns,....

SO,....if you had a single horn from factory would it have came with an extra blade connector present ?

after looking at TSM it appeared the green wire coming from the head light wiring harness near radiator must be the horn,...

so I connected the cut green wire dangling from horns to that wire.......still no horn,...

but still have not bought a horn relay to see if that is it,....

does anyone on this forum see any mistakes I made or have advice ????


P.S.
the 3rd pic is to show the door with 41 year old single stage, that I polished for the heck of it,...it brought the color back and matched the flat base coat I spray bombed the fenders and bed with

that I got from automotivetouchup.com,...they give a good match, I can tell you that !!! ( sprayed it in door jamb to see how close the match was,...and you can't tell where I sprayed it,...dead on....

thanx
dave in NC:)
 

Attachments

·
Registered
Joined
·
123 Posts
Discussion Starter · #5 ·
well last night I really pressed on the horn button, in one location, near bottom 6 o'clock position
it honked, but very whimpy and not loud'

removed horn button cover
mashed all around and in some locations I got the wimpy horn tone
but sometimes I wold press in same location several times and it sounded sometimes and sometimes not,....
any advice for a doofus like me to make any adjustments in the contacts
and what is making it a wimpy sound,.....just one horn,... or is that a sign of a damaged horn, etc ?
 

·
Registered
Joined
·
901 Posts
here is a photo of what I have...

WHEN I GOT THE TRUCK,....the horn had one blade connector on it, and one blade connector dangling, and one green wire coming from them that had been cut........and no evidence of there ever being dual horns,....

SO,....if you had a single horn from factory would it have came with an extra blade connector present ?

after looking at TSM it appeared the green wire coming from the head light wiring harness near radiator must be the horn,...

so I connected the cut green wire dangling from horns to that wire.......still no horn,...

but still have not bought a horn relay to see if that is it,....

does anyone on this forum see any mistakes I made or have advice ????


P.S.
the 3rd pic is to show the door with 41 year old single stage, that I polished for the heck of it,...it brought the color back and matched the flat base coat I spray bombed the fenders and bed with

that I got from automotivetouchup.com,...they give a good match, I can tell you that !!! ( sprayed it in door jamb to see how close the match was,...and you can't tell where I sprayed it,...dead on....

thanx
dave in NC:)
I have a 77 with three horns on it. One on the drivers side and two on the passenger side. That extra pigtail is for the second horn on the pass side. I'm wondering if someone cut off a pass side harness and spliced it in on your drivers side.
 

·
Registered
Joined
·
123 Posts
Discussion Starter · #7 ·
I WONDER WHAT HAS BEEN DONE MYSELF.....
maybe someone will know more than I do.....
 
1 - 7 of 7 Posts
Top