Dodge RamCharger Central banner
1 - 5 of 5 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter · #1 ·
Hey guys I’m a little stumped on this one looking for some help. I’ve got a 1993 dodge ramcharger with the 5.9L magnum and a automatic overdrive transmission. Lately the transmission will not shift into 4th gear/ overdrive when cruising on the highway. So far I have replaced the tps and checked all grounds. I wasn’t sure where to go from here because I have had 5 different people tell me five different possibilities. I am hoping you guys can point me in the right direction as it really sucks that it’s not working. Thank you for any assistance
 

·
Registered
Joined
·
232 Posts
The large snap ring that holds the overdrive friction disc pack in place may have Bro em.  They are notorious for that.  The easiest way to check that is drop the pan and if you have snap ring bits stuck to the magnet then you found it.  It could also be the valve body overdrive control.
 

·
Registered
Joined
·
31,877 Posts

·
Registered
Joined
·
2,536 Posts
All of the above. On my 95 Ram had the same problem, the speedometer wire being disconnected caused it.

Bucky
 

·
Registered
Joined
·
2,709 Posts
I had that problem after changing the tcase output seal. Turns out when I re-installed the speedo drive, I didn't clock it correctly for engagement. No signal, no OD.

Is there a temperature sensor built into the engagement circuit like it is on the diesels? If so, something else to check.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top