Dodge RamCharger Central banner
1 - 16 of 16 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
I changed 02 map & temp sensors timing is 10 deg btdc Im quite sure all vacuum hoses are ok  good fuel(fuelpressure ) spark etc. almost new plugs  & it runs pretty damn good ,

much stronger & only bogs or hesitates once in a while or when I put my foot down too much all at once since im getting part happy  one of the only things I  didnt try yet is a tps  , hopefully that helps also I cant find any damaged wires  anywhere near any of the sensors either so hopefully this is fully gonna fix it ?
 

·
Registered
Joined
·
29,328 Posts
did you pull apart the connectors at the back of the right valve cover and clean them and put new dielectric grease in / also do the same to the PCM conector
 

·
Premium Member
Joined
·
24,598 Posts
The TPS is one of the simplest to test. Within a matter of seconds, you can usually know for sure whether it or it's supply wires are faulty. Digital or analog meter required. If analog, a 0-10vdc range is required. If digital, set to a manual mode of 0-20vdc. If it is digital but cannot be set to manual mode, just move throttle slowly and smoothly. The voltage makes a smooth climb up from around .7-1 volt up to atleast 3 volts or more, never once dropping down to 0 or having erratic spikes and static.

Does not require removal or unplugging to test, as long as you backprobe the backside of the connector with they key on, engine off.



 

·
Registered
Joined
·
70 Posts
Discussion Starter · #4 ·
I havent cleaned computer connections yet , as far as the tps I  bought one yesterday & put it on before ( checking this site again for replies ) I even put on another iac motor I had lieing around off another throttle body I had  now it runs great with only a small hiccup off idle runs & idles smooth & pulls nicely while moving .

I thought of cheating & turning the screw on iac  a bit to raise idle so the rpms would already be there a bit & get past the bad spot ? & bump up timing a bit for better performance  ???

I did have my chiltons bible out & although I hate electrical & tuning type issues I got  a lot of funny readings on sensors  & only bought an 02  &  tps  I had piles of  other tbi parts to try out for free now if I can just get past that bad spot ???
 

·
Premium Member
Joined
·
24,598 Posts
I would recommend the proper adjustment if you tweak with the IAC. The relearn procedure, not random turning of the screw.

You will need a precise tachometer to adjust. Reason is, you don't adjust the screw for curb idle.....you adjust it to 2850rpm high idle, then it handles the rest. Of course, it and the coolant temp sensor are to be disconnected during the adjustment.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #6 ·
I havent touched it yet it rained like hell yesterday & mothers day today but while I drove it a bit yesterday it was crappy again with an on off on off stutter like its electrical  like a spark thats missing  all wires coil hall effect plugs cap & rotor are good so Ill try spraying & drying out computer  & put electric grease on prongs  I cant find any damaged wires from hall effect  or anywhwere else ??
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #8 ·
I dont wanna jinx myself but it seems fixed for good this time I cleaned up all computer connections  & every other wire connection that wasnt nailed down & used dialectric grease on everything & found some coroded plugs here & there .....  now it runs good no stumble or stutter & I guess its as strong as its gonna be turning hwy . gears & 33's  I hope it stays that way ! thanks for all replies as to where to look
 

·
Registered
Joined
·
154 Posts
dave14 said:
I dont wanna jinx myself but it seems fixed for good this time I cleaned up all computer connections & every other wire connection that wasnt nailed down & used dialectric grease on everything & found some coroded plugs here & there ..... now it runs good no stumble or stutter & I guess its as strong as its gonna be turning hwy . gears & 33's I hope it stays that way ! thanks for all replies as to where to look
okay I have a couple ? What did you find coroded? And the other ? When you say shuttering does that mean kinda it act likes it missing but it doesn't slow down it just keep running and then a couple of seconds it does it again For me when I let off the gas going down hill it does the what I call a herky jerky thing it acts like the ujoint or driveshaft is loose and it kinda stumbles like it trying to catch up to the speed of the engine so that is what I call stumbling I've had the same problem for about 3 monthes and I can't figure out whats is causing it's not bad it's just a nucience.
 

·
Premium Member
Joined
·
3,113 Posts
For DC

Could it be your lockup torque converter messing up?  (if equipped) if it wasn't unlocking during part or no throttle coasting it might cause jerking.  Usually associated around speeds of 40-50 mph


Cheers

Chris
 

·
Registered
Joined
·
154 Posts
v737d said:
For DC

Could it be your lockup torque converter messing up? (if equipped) if it wasn't unlocking during part or no throttle coasting it might cause jerking. Usually associated around speeds of 40-50 mph

Cheers

Chris
I don't think I have one Its an old plain Jane 88 ramcharger with 70K original miles on it
 

·
Premium Member
Joined
·
3,113 Posts
Is it 4x4 or 2wd?  My 87 and 88 2wd both have lockup TCs.  I don't think the 4x4s used the lockup tqss



Cheers

Chris
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #13 ·
it ran poor off idle & pullin itself up to speed it was on off kind of stutter I cleaned up back of computer it didnt look bad & where I did find funky connections was on passenger side back of engine (maybe one of those fed hall effect ) its still good now & it got a well deserved 02 sensor  (never changed ) & a tps  everything else I threw at it I had & didnt cost me anything  after all that Im still gonna put a carb on it someday , but its never ran this good I cant wait to get 4.10 s to get it moving better
 

·
Registered
Joined
·
154 Posts
v737d said:
Is it 4x4 or 2wd? My 87 and 88 2wd both have lockup TCs. I don't think the 4x4s used the lockup tqss

Cheers

Chris
sorry 2WD I forgot that Wasn't the lock up a option or standard I would have to ask uncle about but I think they bought the plain Jane one no options nothing other than A/C was on the ram But like I said I would have to ask the uncle to. Today it went for state inspection and passed my freind ( mechanic for living ) took it in for the inspection and he said that he thinks that either the pressure regulator or a injector is messed up so he said he would look at that this weekend and see if we can find it. It makes sence because as soon as you let off the gas it loads up the injectors because if I keep my foot in it it runs fine so I'll check the fuel regulator again last time checked it it was running perfect so it may be bad now Ill keep y'all informed to what I find.
 

·
Registered
Joined
·
154 Posts
dave14 said:
it ran poor off idle & pullin itself up to speed it was on off kind of stutter I cleaned up back of computer it didnt look bad & where I did find funky connections was on passenger side back of engine (maybe one of those fed hall effect ) its still good now & it got a well deserved 02 sensor (never changed ) & a tps everything else I threw at it I had & didnt cost me anything after all that Im still gonna put a carb on it someday , but its never ran this good I cant wait to get 4.10 s to get it moving better
is that the 3 solinoids your talking about? Purge,egr, can't remember the third one but I'll look at those
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #16 ·
all my pollution etc. is off right now no egr air pump vacuum canister etc. I taped up those 3 solenoids  the corroded connections that were possibly troubling me  joined into the main harness on passenger side back of engine ( near those solenoids ) & I suspect one of those may have fed hall effect  my computer looked clean also  but since i was in there I cleaned it up as well as just about every connection I could get my hands on & inspected all the wires
 
1 - 16 of 16 Posts
Top