Dodge RamCharger Central banner
1 - 8 of 8 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
Did a search and couldn't find anything related to my problem.
What I have is an 85 W150 with a 360 in it. Replaced the starter about 3 months ago along with alternator.
What I get when I turn the key is a click that seems to be coming from under the steering column, sometimes after I turn the key few times I will get a connection and it will fire up. Anyone know what would cause this, cause I sure is hell dont.
 

·
Premium Member
Joined
·
8,998 Posts
sounds like it may be time for a new starter relay...they are like 10 bucks.

Also check all your wiring from the battery to the starter and then back thru the ground lines. It may just be a loose connection. Check the battery connections too.

It is possible that the starter has gone bad too, so don't rule that out.
 

·
Moderator
Joined
·
2,317 Posts
does it have tilt? the ingtion switch is mounted on the top side of the column.just look under the dash on the top of the column to see if there is wires going to a switch with a rod attached from the top of it. maybe steveo(chump) can get you a diagram.good luck
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #4 ·
It doesnt have tilt, and I havent driven it since I've bought it 3 months ago. Just been working on it. I've started it up a few times and let it run for 10 or 15 min but thats it. So I dont think the starter is fried. I've checked all the wiring from the starter back to the battery and the connections are all clean and look good. This is just irritating cause It started up fine and then I got her registered the other day and wanted to take her out, and now she doesnt want to start. :mad:
 

·
Registered
Joined
·
115 Posts
i hope this helps ...check to see if ya have a small rod going down the coloum and when ya try to start it wiggle the rod and see if it starts.....i had the ignition switch replaced on my truck and now when i start it i have to puch that lil rod up to make the connection then it will start....lol
hope this helps
dave
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #8 ·
Spacedog, I checked and I dont have that rod your talking about.
So, just to make sure that my starter wasnt the problem, I just unhooked the cable from the relay to the starter and touched it up against one of the empty connections on the relay that was providing juice and the starter kicked over fine. I dont know much about electrical and my chiltons manual doesnt seem to be helping me right now.
I do have a question though, if turn the key to the "on position" should the connection on the relay that has my starter wire turn hot?
 
1 - 8 of 8 Posts
Top