Dodge RamCharger Central banner
1 - 10 of 10 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
hey guys again. 74 W100 69 318 in 74 truck elec. ignition. drove my truck to work and home the other night (80 miles) ran great although still detonating a little. got home, truck idled fine. didnt run the truck yesterday got in it today started it with man. choke in at around 1200 rpms. ran fine warming up, as soon as i kicked off the choke it died. have tried to adjust idle speed, checked fuel filter, plug wires, all the usual suspects. nothing abnormal. although if i unplug the conn. to the dist. and ground it i can hear a clicking but can't tell where it is coming from. could the ecu be the problem? would think it wouldn't run at all if that was the problem. HELP??????????? :mad:
 

·
Premium Member
Joined
·
4,879 Posts
Checked for vacuum leaks?

Quick check--with it running (with the choke off as much as possible) place your hand over the carb throat. If it doesn't stall almost immediately, you have a large vacuum leak.

-SM
 

·
Registered
Joined
·
3,489 Posts
check the ignition module and the balast resistor. ive seen both just die one kills the power to the coil(balast reststor) the other kills the spark from the coil. either way if it was running then just died and wouldnt restart i would expect a bad balast reststor
 

·
Registered
Joined
·
2,818 Posts
i had a similar problem with my 77 PW.... it would run great and when i came to a stop or hit the brakes after warm up it would just flat die and not restart till it cooled down. replaced everything but the dist and it was still dieing... replaced the distributor and no more problems.. i t hink i paid like $52 at autozone for it....
 

·
Registered
Joined
·
134 Posts
Discussion Starter · #5 ·
yeah, just pulled the dist. about 3 weeks ago and cleaned and replaced the springs. I am thinking i may not have relubed it when i put it back in as well as i should have. am wondering what happens when the bushing in the dist. is gone? kinda makes sense, with truck running at around 1000 rpms the rpms seem to want to hunt and peck but with no regularity. just wondering if it could be causing a variation in spark quality therefore causing the low idle death and mid range hunt and peck. what do you guys think? probably will pull the dist. tomorrow.
 

·
Premium Member
Joined
·
9,424 Posts
That would sure do it... the wandering rpm is the clue.
 

·
Registered
Joined
·
12,472 Posts
Yeah readit man . ummm...sems like u are on the right trail though lol . Will look back later and see what u found out .
 

·
Registered
Joined
·
134 Posts
Discussion Starter · #8 ·
sorry everybody, i haven't had time to pull the old distributor yet, i have been sick and with three kids well, don't have a whole lot of time. does anybody know if mopar still sells one of the old dual pickup distributors? and are they any better than the single? not sure, let me know please
 

·
Registered
Joined
·
134 Posts
Discussion Starter · #9 ·
sorry everybody, i haven't had time to pull the old distributor yet, i have been sick and with three kids well, don't have a whole lot of time. does anybody know if mopar still sells one of the old dual pickup distributors? and are they any better than the single? not sure, let me know please
 

·
Registered
Joined
·
12,472 Posts
Yeah u can replce it with a double look on e bay for a mallory u might find one dirt cheap like 30 bucks if u look . Ask Chump how to wire it up i can't rememeber right off the top of my head nad i whooped and going to bed lol .
 
1 - 10 of 10 Posts
Top