Dodge RamCharger Central banner
1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
first let me introduce myself

names jim I'm from WI and just bought my first ramcharger,it's an 88 4x4 w/318fi. everything is still stock(for now)

anyways it's been sitting for the past 3 years and was haveing starting problems,so I replaced the starter and starter relay yesterday now the speedo doesnt want to work.it worked before the swap. any one have any idea's what my prblem could be.
 

·
Registered
Joined
·
1,302 Posts
Check if the speedo is connected behing the guage. It pops off easily. Your going to have to take off the bezel i think it is to check.
 

·
Registered
Joined
·
2,818 Posts
just make sure it is hooked up at both ends. maybe someones messin with ya :)
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
it is still connected at the transfercase,but havent gotten a chance to check behind the cluster yet.
I might of nocked it loose yesterday messing with the ignition switch.
my concern is that this thing has a slew of wiring problems,everything from corroded/exploded wiring to completely missing wires.
 

·
Registered
Joined
·
240 Posts
jimmyb glad to have u at ramchargercentral, if u ever need help badly just give me an email, i would be glad to help u, i have been to sheboygan a few times for hockey tournements.
 

·
Registered
Joined
·
1,894 Posts
The inner cable could be broken, pull it out and see, usually it's the last/first few inches near the connectors.
 
1 - 6 of 6 Posts
Top