Dodge RamCharger Central banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
426 Posts
Discussion Starter · #1 ·
Hey RCC!

Well, I'm really hoping for some info here that helps me avoid a worst-case-scenario.

Today I primed my engine, in preparation to fire it soon. I had a helper turn the engine over with the ignition key while I use the drill to prime the pump. After a few seconds, the driver side rockers were getting oil. Passenger side was dry. We kept at it for another 4 attempts, but still never got oil to the passenger side. The last attempt was about 10 seconds long, with drill going and engine turning over.

Doing some research I'm seeing some talk about the cam bearing being out of alignment.
I'm really, really hoping that is not the case. I would be crushed to get this far into my build just to have to pull the engine.

Is there anything I can check or maybe I'm missing here? Pics below.

Thanks for any replies.

Motor vehicle Coil spring Gas Machine Metal
Motor vehicle Automotive tire Light Automotive wheel system Automotive exterior
Motor vehicle Automotive tire Hood Wood Tread
Light Motor vehicle Automotive exterior Auto part Gas
 

Attachments

·
Premium Member
Joined
·
426 Posts
Discussion Starter · #3 ·
Rotate the crank 90 degrees, prime again, repeat another 90 degrees, etc, until you get oil out both sides.
Ok, I'll give that a try. So, rotate the crank and then prime, not at the same time as the crank rotates?
 

·
Premium Member
Joined
·
426 Posts
Discussion Starter · #5 ·
Thank you ToxicDoc. Great advice. I cranked it by hand and was able to get some oil through the passenger rockers. Then my drill battery died, but I'm happy.
 

·
Premium Member
Joined
·
426 Posts
Discussion Starter · #8 ·
I’ve never cranked the engine over with the key while priming, just use a drill and rotate by hand, you’d spin it too fast with the ignition I’d think
So what happens when the engine is running? It's spinning a lot faster than it would by hand. This is an honest question, I'm not being a smart ass.
 

·
Premium Member
Joined
·
426 Posts
Discussion Starter · #16 ·
If it is your first engine rebuilt, Congrats.Not to many people can experience having connecting rod in your hand and the next thing witness it coming alive. I get emotionnal each time an engine fire up.
From the picture, I see a lot of new parts, you put time and $ in it.

Maybe not filthy, but without valve cover for some time.
This engine also seem dry. Not a lot of engine assembly lube/grease. I believe Metal-to-metal surface have to have engine assembly lube. Maybe it is just me.

No shame of spinning the oil pump with drill for 20 minutes right before start-up. 2-3 minutes per quarter turn (with wrench) on engine, and at least 4 complete engine turn. without spark plug of course.
I may be overly priming the pump, but who care?

I strongly believe that the first 2 minutes of startup of an engine are critical. So very close to us on first start are the usual stuff (maybe you are familiar with this):

check spark and fire order, multiple time by multiple people. It save us a couple of time. specially on Ford engine.
oil pressure gauge. I would remove the oil pressure sensor and install an oil pressure gauge on first start. it must read pressure while spinnig with drill.
timing light already hook up.clear mark on balancer.
fire extinguisher
infra red heat gun (reading exhaust temp and engine temp, thermostat specially new one can be tricky)
water hose to cool radiator, first start generate a lot of heat.
Dedicate helper on dedicate task.

There is a lot more step, but just in case
All very good tips. I will make sure to follow these steps you've outlined.

Not sure if you've seen my build thread, but if you have a few minutes you can see the progress here...

 
1 - 5 of 5 Posts
Top