Dodge RamCharger Central banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 90 ramcharger. The radio quit working .radio second wire or red white is powered . tested from groung wire to red white. no power to face of radio or display. Tried another radio and it will not work either
 

·
Registered
Joined
·
2,818 Posts
the easyest way to deal with that.... aftermarket stereo on run new wires for everything. otherwise try running a second ground off the radio to the firewall...
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
moparPW200guy said:
the easyest way to deal with that.... aftermarket stereo on run new wires for everything. otherwise try running a second ground off the radio to the firewall...
hooked up 12 volt to pin 2 and 3 on radio display lites up where could i get scamatic to find out where the 7 wires go
 

·
Registered
Joined
·
29,666 Posts
as the great CHUMP would say everybody should have a Factory Service Manual for there truck
FSM dude
 

·
Premium Member
Joined
·
4,879 Posts
You need to check three wires with a voltmeter or test light.

1) Red - Ignition switched power
2) Yellow - Constant 12 volts (hot at all times)
3) Black - Ground

Check the red and yellow wires for power (with key in accessory or run position for the red wire) at the connector. Use the black wire in the connector as your grounding point for the voltmeter/testlight to verify you have a good ground.

I had this problem in my '87, and it turned out the pins for the yellow wire in the connector were no longer making good contact - which meant no juice to the radio.

And if you haven't already, check the fuse.

-SM
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
orca said:
I have a 90 ramcharger. The radio quit working .radio second wire or red white is powered . tested from groung wire to red white. no power to face of radio or display. Tried another radio and it will not work either
Thanks for the help install doc helped . had three problems . in line fuse on pink line - fuse from headlight switch - and bad antenna contact .tunes coming in loud and clear tx again
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top