Dodge RamCharger Central banner
1 - 2 of 2 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter · #1 ·
Hello,
i got an issue with my passengers side power window on my 1984 RC.

When only the ignition is on the window motor barely manage to wind the window up. Sometimes it just stop.
When i start the engine everything is just working ok, not perfect, but ok.
The driver´s side window is a lot faster and works like a charm.

For me it seems to be lack of power/current going to the motor. Relay or bad ground? Or is this the first sign of a dying window motor?

thanks. Cheers
Flo

 

·
Registered
Joined
·
13,500 Posts
my '93 is the same way , ya gotta remember to up the winder before ya shut the engine off , seems to get more power when the alternator is running , so what feeds the relay? ( relay?) a fuseable link ? off the battery ( 12 volts off / 13.8-14.3 running ) maybe that 1.8-2.3 voltage increase is enough to be seen as window speed due to the drag on the glass from weatherstripping ? pass side used less than driver side , don't move as freely ? electric is 2 things , amperage , and voltage , like a starter , when your battery is weak it draws( needs) more amperage as the voltage drops ...  12 volts and a thin cable works ok ,  8 volts ,and same cable smokes . do you have new tight weatherstripping ? broken jamming weatherstripping ? dry lubeless window regulator? 
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top