Dodge RamCharger Central banner
1 - 5 of 5 Posts

·
Registered
Joined
·
466 Posts
Discussion Starter · #1 ·
ok i put my new motor in.
hei dodge distributor and ford ecoil.
got everything buttoned up and was getting ready to time it .
started cleaning up all my mess and tools instead.  
backed it off of the driveway to park in a differrent spot to hose off all the mess and oil trans fluid ect.   and i noticed a oil spill like the exon vadeez.  
i climbed under to see if the oil pan was leaking but it was every where.  had my wife start it while i was under it and it looked like the oil filter was leaking.
so i took the filter off and the gasket was good.
put it back on and started it again.   it looks like the adapter plate is leaking, and it is on tight or o thought it was .
how much tourqe does it go on with?
i tookit off to see if it is warped and put it on some glass and it seems to be ok.
if it were the rear main wouldnt it be coming out of the transmission inpection plate?
it has a lot of pressure on it so i am thinking maybe 20 ft pounds of tourqe wasnt enough
 

·
Super Moderator
Joined
·
29,558 Posts
Agreed, there is a large round gasket that must go between the plate and the block to seal it.
 

·
Registered
Joined
·
466 Posts
Discussion Starter · #4 ·
yes i did. and i used a little indian head to hold it in place.
that might be my down fall. 
the one  got from the junkyard came off with a couple taps from the ratchet, so i dont think it tweaked it.
 

·
Registered
Joined
·
466 Posts
Discussion Starter · #5 ·
it is under a lot of pressure the oilpan gasket woudnt spray like this would it? 
i did overfill the oil to help prime the pump but i let it out before starting it.
i ordered another gasket from napa and i will try it again tommorrow.
mabe i just got a little dirt on the gasket area and it caused a leak.
i swear that this project has fought me the whole way.
i am about $600 overbudget and two weeks behind .
every time i get some time to work it is raining.  i put the motor in bolted up the trans and was starting to slide in the motor mounts when the hundred year rain came .
i had to run in and pull the shower curtain off and use it to keep the rain out of the motor.
this has been a nightmare.
i swear that i am ready to go amish
 
1 - 5 of 5 Posts
Top