Dodge RamCharger Central banner
1 - 6 of 6 Posts

·
Registered
Joined
·
293 Posts
Discussion Starter · #1 ·
I was trying to pull a friends stuck bronco out of a mud hole today. When I had the truck in four hi and took the slack up in the chain the didnt even go. Didnt spin the tires or anything. But when I put it in four low it finally moved and spun all four. Didnt get the bronco out(stuck halfway up the wheels in mud and I was in wet grass and mud. Could this be my kickdown linkage again doing this. Or is there something with my carberator or drive train. I was in first on my automatic trans I even tried drive and it did the same thing. Any help with this will be appreciated. Certainly has me stumped.
 

·
Registered
Joined
·
299 Posts
After the attempted bronco extraction, were you able to run in hi? 2wd? 4wd? This doesn't sound like anything to do with carbs or the kickdown linkage. A little more detail would be helpful.

Bruce
 

·
Registered
Joined
·
293 Posts
Discussion Starter · #4 ·
I was able to drive in four hi but once the slack was taken out of the chain and the load was on the truck the truck wouldnt move or even spin the wheels or anything. But once in four low it spun the wheels. I dont know if this helps.
 

·
Registered
Joined
·
3,489 Posts
Sounds like 4 hi is working fine to me. You just did'nt have the porew to spin them in hi range
 

·
Moderator
Joined
·
29,447 Posts
I agree with Sledge and gmule.
Also, always use 4 low when extracting somebody from a good stuck. What are you saving 4 low for anyway??? ;).
 
1 - 6 of 6 Posts
Top