Dodge RamCharger Central banner
1 - 9 of 9 Posts

·
Registered
Joined
·
996 Posts
Discussion Starter · #1 ·
What a dumbarse, Can I get an award for being this dumb. The hazard switch was on not off I was going opposite to turn em off, they werern't working so I coud'nt tell if they were on or off everything works 'cept the hazards :-[
Thanks
 

·
Registered
Joined
·
193 Posts
if you had you trailor lights hood up, you could have either pulled the plug wire tight enough to pull loose at the connection or to pull(strip a wire) and cause grounding.... I would check the plug connection under the rear of the truck and see if it is loose(dirty coroded etc)
 

·
Registered
Joined
·
996 Posts
Discussion Starter · #3 ·
Well I took it all apart, someone spliced the the trailer plug in and I was going to redo it, but not so soon. I'm just not getting juice to the back but I'm getting parking lights ok, so i figured it is in the brake turn circuit, Can you burn out an old blinker and brake switch by pulling a trailer?
 

·
Registered
Joined
·
193 Posts
emergency, and turn flashers should be seperate - did you try emergency flashers? then you have a fuse as well (as I recall)... not sure what else... do you have power brakes hooked up?
 

·
Registered
Joined
·
996 Posts
Discussion Starter · #5 ·
no trailer brakes, just light pigtail
 

·
Registered
Joined
·
10,220 Posts
yeah maybe the extra strain on the circuit speacially if they havnt been used witha trailer for a while or at all. I would try replacing the swith and blinker fuses
 

·
Moderator
Joined
·
7,995 Posts
Check to make sure the hazard switch on the steering column is not positioned between on and off. As mentioned before try the hazards and see if they work.
 
1 - 9 of 9 Posts
Top