Dodge RamCharger Central banner
1 - 7 of 7 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Got it bout a month ago. Has it's issues as so many others do. Windows dont work(electrical) oil pan leaks(seals), and the heat seams to always be on(?). But it's pretty sweet. 318 bored 40 over, 4x4 that works perfect, and a 4" body lift. I might try to put 2" blocks under the leafs but haven't decided yet. Gotta figure out the stupid little things first. But here's a pic of it next to my lowered bug.

 

·
Vendor
Joined
·
11,515 Posts
Welcome to the greatest site on the net!!!!!
You have 2 COOL toys there!!! Your RC looks like it's in very good condition. What state are you from?
When it comes to blocks under the springs, DON"T EVER put them under the front springs!!!!!!! That is a BIG safety concern!!!! Any questions just ask & some one should be able to help.
Jim
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #4 ·
Thanks a lot guys. Good trash to know. I woulda never guessed that blocks under the front is bad. I'm from Ca but stationed in NC. Bought the truck in Missourii and it has absolutely no rust which is amazing to me.
 

·
Registered
Joined
·
1,663 Posts
Lift blocks are very bad up front, my first RC had some mini truck lowering blocks in it when I bought it from a wrecking yard, one had spilt and sent it into a guard rail, wiped the right side out on a rust free '74 1/2 door 440 RC. It could have killed the driver or someone else had it gone into oncoming traffic.
 

·
Registered
Joined
·
857 Posts
1987RCboy said:
Thanks a lot guys. Good trash to know. I woulda never guessed that blocks under the front is bad. I'm from Ca but stationed in NC. Bought the truck in Missourii and it has absolutely no rust which is amazing to me.
Lucky you nabbed that thing up before I found in Missouri! Welcome to the site and your bug is awesome you should post some more pics of it in the "Other rides" section.
 
1 - 7 of 7 Posts
Top