Dodge Ram Cummins Diesels and Mopar banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,058 Posts
Discussion Starter · #1 ·
Alright yesterday my truck was runnin perfect..now today.. I go out to fire it up, it's being extremely cold blooded. It finally warms up..but still won't idle, and it's opened headered right now. It sounds like a tractor..yesterday it sounded like a drag car. It has NO power going down the road today, barely could do 35. ANy ideas?

Also..I just read a post with somethin about platnium plugs..I just put them in my truck, could that be my prob?

Sean
 

·
Registered
Joined
·
1,194 Posts
my .02: Crossed ignition wires, platnum plugs with old ignition wires or coil. Carb fuel problem. Stuck choke plate. Idle mixture. I have have a similar problem and sprayed carb cleaner and it cleared up whatever problem i had. Maybe vaccum line off also. Good luck,
 

·
Registered
Joined
·
1,058 Posts
Discussion Starter · #3 ·
Well the wires aren't crossed, check that about 5 times cause I wanted to be positive cause that was my first guess.they are old wires..I dont know how old, were on it when I bought the truck..old coil too, at least 9 years. Could this be my problem? It doesn't seem like it's the carb casue it was fine yesterday.

Sean
 

·
Registered
Joined
·
1,194 Posts
Sean: when changing plugs you might have pulled a vaccum line off something. Its really strange that you turn it off fine and it starts up and runs bad. Theres been some bad comments on those platnum plugs i think. What about installing the old plugs back in (work!) and seeing what happens. Hope you still have them. What about proper gap on the plugs? (really reaching now!!) :-[ Don

The thread on this board "Dont Get This" is talking about platnum plugs not working with Accel coils. Is yours Accel. My .02 is to dump the platnum plugs. Take them back to the store and tell them they don't work.
 

·
Registered
Joined
·
1,058 Posts
Discussion Starter · #5 ·
It's not that I'm lazy and not doin the work..heheh. I just can't work on it right now really cause my neibors get made if I run it at night..I wanted to see if I could come up with some possible solutions so I can go right at it tomorrow :)

Sean
 

·
Registered
Joined
·
1,194 Posts
I modified my message while you were responding. See above!
 

·
Registered
Joined
·
1,194 Posts
Problem solved! For what you paid for plugs might be able to buy new coil!! :D
 

·
Registered
Joined
·
1,058 Posts
Discussion Starter · #9 ·
LOL yep, I have a stock coil I could throw in it, the only problem is that somebody..prolly my bro..lost the rubber thing that goes in a spark plugs socket and didn't mention it, and I busted one of the platnium ones in half, DOH!!

Sean
 

·
Registered
Joined
·
1,194 Posts
Take um back, they will never notice it!
 
1 - 10 of 10 Posts
Top