Dodge RamCharger Central banner
1 - 11 of 11 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Does anyone know about why these aftermarket motor mounts do not seem to not line up properly ? When there installed it lloks like the motor sits to far foward and the mount is all most stretched in the K-frame. Any suggestions ?
 

·
Registered
Joined
·
1,183 Posts
Questions: were the old mounts also twisted in the same way as the new ones? Are the studs in the same place on the new ones as on the old ones, length, etc? Do they look the same?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #4 ·
They were same as the old ones. It just seems like the new mounts don't fit properly. I am wondering when I had the transmission replaced a couple years ago that the replacement transmission was different. Because the tranny mount did not fit properly either.
 

·
Registered
Joined
·
1,183 Posts
You might be on to something there but some of the other guys might have part numbers for your correct motor mounts and then you can compare to what you actually bought and go from there.

denros said:
They were same as the old ones. It just seems like the new mounts don't fit properly. I am wondering when I had the transmission replaced a couple years ago that the replacement transmission was different. Because the tranny mount did not fit properly either.
 

·
Moderator
Joined
·
7,995 Posts
Was the truck ever in a wreck? I had a bent crossmember on a 77 New Yorker that I didnt know about until I tried to pull the tranny. It was in a wreck and was never fixed correctly. Previous owner pocketed the insurance money for part of the repairs.
Motor mounts should look like this...do they?


Tranny mount look like this? should have slotted mounting holes. Could they have installed it backwards?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #8 ·
The mounts look exactly like the pictures. But it just seem like both the motor and trans is sitting to far foward.
 

·
Moderator
Joined
·
7,995 Posts
Well if the mounts are correct and installed correctly then i would say it may be the replacement tranny they put in? You say thats when it all started? I would unbolt the tranny mount and maybe the tranny crossmember and see what happens to your alignment.
 
1 - 11 of 11 Posts
Top