Dodge RamCharger Central banner
1 - 15 of 15 Posts

·
Registered
Joined
·
1,313 Posts
Discussion Starter · #1 ·
:\'(well the truck decide to be a bitch today. went to work and ran fine go to leave for home and the tranny wont down shift into 1st. so if i dont get it fixed or it starts working again ill be down for the count. :\'(
 

·
Registered
Joined
·
1,313 Posts
Discussion Starter · #3 ·
its an auto. it acts like trying to start out in 3rd gear and dumping the clutch on a standard.
 

·
Registered
Joined
·
1,313 Posts
Discussion Starter · #5 ·
what sux is the converter is only 3 yrs old and it cost $275 to replace it. the trans will cost $450-$500 to rebuild. if i come it maybe in a nondodge.
 

·
Registered
Joined
·
1,313 Posts
Discussion Starter · #8 ·
all the gears work the fluid is good and no odor. have to read up in my book for the band adjustments. hoping its something simple. look at it in the morning. im ready to pour gas on it.
 

·
Registered
Joined
·
11,632 Posts
tjones85 said:
what sux is the converter is only 3 yrs old and it cost $275 to replace it. the trans will cost $450-$500 to rebuild. if i come it maybe in a nondodge.
what kind of converter cost that much. is it a small block. i haVE A NEW CONVERTER FOR IR.
 

·
Registered
Joined
·
1,313 Posts
Discussion Starter · #10 ·
its a 904 w/ lock-up. its driving me nuts to cuz its my only mode of transportation. tried beating on the tail shaft with a rubber hammer thinkning maybe the gov. was stuck.

i keep getting different anwsers. the front pump going out, the gov. stuck, or the t/c is stuck.

its just weird that i go to work and its fine and go to leave 9 hours later and its acting up.
 

·
Premium Member
Joined
·
2,209 Posts
dont feel bad the trans went outta my rc i think. i can take off in 1st but not in any other gear. but after i hit about 25 its find just cant take off in any gear but 1st. 4wheel drive dont work so i dont have a clue what i could be.
 

·
Registered
Joined
·
11,632 Posts
Mine won't shift out of low. I have reverse and nuteral. Fluid is fine it just won't shift to second or Drive.
 

·
Registered
Joined
·
5,049 Posts
try pulling it to low or 1st and see if it starts in 1st or trys to go in 3rd. if it starts in 1st like it should you most likely have a stuck vavle in the valve body, if it still tries to start in 3rd then it is most likely the governor is stuck, whas it 2 or 4x4?
 

·
Registered
Joined
·
11,632 Posts
I can manually put it in low and it will take off fine. Just won't shift. Take off in Drive and thats where it is in third, but I can manually shift into low, but it will not shift into second at all.
 
1 - 15 of 15 Posts
Top