Dodge RamCharger Central banner
21 - 40 of 50 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter · #21 ·
ofelas said:
What was the original relay PN and what PN did you replace it with?
green 4222060
 

·
Premium Member
Joined
·
6,811 Posts
dash stays on, mine had a "belt" that allowed it to clip onto a metal tab.
 

·
Registered
Joined
·
126 Posts
Discussion Starter · #24 ·
Mike Barf said:
dash stays on, mine had a "belt" that allowed it to clip onto a metal tab.
No need to remove the dash.
 

·
Registered
Joined
·
245 Posts
Tried both a new 4312002 u it as well as a NOS 4222060 unit.
Both have the same issue - wiper works in low speed when the wiper switch is in both the "off" position and the "low" position.

Wiper works at high speed in the "high" position.

The existing box on the truck is the 4503104 u it tht works correctly in low an high, but dead in the delay positions.
 

·
Registered
Joined
·
1,180 Posts
Add an extra ground to the wiper motor housing.  I've found that the timers are very sensitive to weak grounds of the motor.

It may as simple as loosening and retightening the bolts holding the motor down.
 

·
Moderator
2013 Ram 1500 2014 Challenger SXT
Joined
·
2,284 Posts
Ruderunner said:
Add an extra ground to the wiper motor housing. I've found that the timers are very sensitive to weak grounds of the motor.

It may as simple as loosening and retightening the bolts holding the motor down.
This is an excellent idea even on the standard wiper motors. I find the factory ground strap to be weak and easily corroded and/or broken.
 

·
Premium Member
Joined
·
6,811 Posts
there are different intermittent wiper modules, not sure how they differ internally, but you mentioned that one part number that worked properly, that is likely the one that you need to use, as the others are designed to work with a different wiring harness, or under different voltage requirements.
 

·
Registered
Joined
·
245 Posts
The 4503104 was on the truck when I bought it but the delay function never worked.
I bought the other two part numbers but they were always on when the switch was off.
 

·
Registered
Joined
·
1,180 Posts
For whatever reason, Mopar in it's wisdom uses the same plug for a lot of these wiper timers.  BUT they are wiried differently. You might be able to swap some by swapping terminals in the plug but you would need wiring diagrams for both setups.
 

·
Registered
Joined
·
1,001 Posts
ofelas said:
Any other insights into this issue? At my wits end.
on my 85 I have low high and the intermed sticks and wipes away for a while, you hear the relay clicking in the dash some times..

i tried a couple of the green wiper delay relays and I get different results.

what I have found tearing into the wiper motor is it has fingers with point contacts and a round disc turn under them like a washing machine timer of sorts.

anyway..the 3 or 4 wiper problems I have solved with the delay not working is to replace the wiper motor, the stock ones can be opened to find the broken contacts in side.

there is also different plug in pieces that goes on the motors, all moter are not delay motors but a 2 speed only,with the piece on motor matching the delay relay box...when the wrong motr is used with a delay switch and delay relay you get it to park but not work in delay mode but have low and high speed.

napa had the new replacment wiper motors for delay mode for about 80$.

I have not run across a bad dash switch or a delay relay myself , it is the motor point contacts everytime so far for me.

I have a 2 speed motor on my 85 harnes with delay, no worky in the delay mode but has low and high...it does park when you move to OFF mode. (waiting on funds to replace it)

same thing with them not parking but delay,low/high speeds work, points in the motor head again.

I did not read all of the post but did see you are at the end of the rope...maybe this might help out.
 

·
Registered
Joined
·
245 Posts
Thanks; any pointers on a part number for the delay motor?

My w150 is an '81, but has the inside controls from an '88...
 

·
Registered
Joined
·
1,001 Posts
not off hand, but they look it up for the yr make of the truck with or with out delay.

you want the plug in piece on the motor(looks like a black sqaure box thing pluged into the motor..and this is the motr that lays on the firwall not sticks straight out from firewall.

I agree with adding the ground strap also, never hurts.

 

·
Administrator
Joined
·
60,705 Posts

·
Registered
Joined
·
245 Posts
So I need the black box that bolts to the motor to be changed?
Could there be a different intermittent wiper arm needed?
 

·
Administrator
Joined
·
60,705 Posts
ofelas said:
So I need the black box that bolts to the motor to be changed?
Could there be a different intermittent wiper arm needed?
The black box on the motor, is just a terminal cover. The wiper delay box, is mounted under the dash near the steering column.

I would put my bet on the wiper switch.
 
21 - 40 of 50 Posts
Top