Dodge RamCharger Central banner
1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Hello, my 318T. F.I.,a/t, RC has the stepper motor that controls the idle I noticed it has been a bit nosy latey and when I put my hand on it when it is operating it feels like the motor is ruff. is this normail or should I replace it?
thanks Brian
 

·
Premium Member
Joined
·
3,113 Posts
Mine has made noises since the day I bought it three years ago.  Mine works  fine. 

Unless your idle is surging ( a high rpm jump  right after start is normal) or rough, I wouldn't worry about it.

It is an electric motor running straight cut gears, as far as I know, and that will always be noisy.

Cheers

Chris
 

·
Registered
Joined
·
1,695 Posts
I bought my RC in 2000, and the AIC motor has made a "whirling" or "buzzing" noise since I bought it.  It still works just fine.  I wouldn't worry about it until you start having problems.
 

·
Registered
Joined
·
29,344 Posts
as long as it moves in and out smoothly and no hearky jerky movement its fine
 

·
Registered
Joined
·
423 Posts
When I had my 89, I just lubed it up well and found it to work just fine despite the noise. 
 

·
Registered
Joined
·
904 Posts
yuh they are noisey; but the one on my sons 89 is bad.... I try thru the "red brick" to hold it at different RPMs it works til ~1200; at 1300, 1400, 1500 it "tries" but I can see it pop and strip, and drop off and it just cant do it... I guess the cyclic surging it was doing on that long maiden drive home, stripped it out; when it tires to work it sure does alot of snapping and popping; I hate the TBI;  about 10-12 years earlier we had Lean Burn (and it's different named but same screwed up deal) and everyone bypassed it, and went on; but I've gotta say that Lean Burn hasn't given me NEAR the fits that this TBI setup does; and this isn't the 1st vehicle I've fought it on, by far....
I HATE this TBI setup!!!!! if the Idle Speed Control had been the "only" issue with this setup, I certainly would not be saying what I am;
you arent the only one to have issues with it; since I have joined RCC I see I'm not either; there are alot of posts esp '88-89 model year, with TBI problems; I see much less posts about "issues" with 90-91 even though it's basically the same.
 
1 - 6 of 6 Posts
Top