Dodge RamCharger Central banner
1 - 6 of 6 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
Hey Guys,

I have a 1989 W150 4x4 and the other day the hood would not latch down when I shut the hood. It has been very
agravating!!!! I have tried to adjust the bar on the hood to no avail. It seems the latch is working but the bar can't get down far enough now to make the catch. I have had the shim the latch up so it will shut but now the hood does'nt line up
up with the fenders. Has anyone had this type of problem before?

Thanks,
WOD in VA
 

·
Registered
Joined
·
5,049 Posts
hey wod, check to make sure that the steel rod part on the hood isnt bent. that is somewhat common to see them bend a bit and then not fully seat in the primary latch. you can always double check the release cable isnt staying pulled too. this is common as well. has anything changed. accident, damage ect. if not look at the rod and make sure it isnt bent and if so try and straigten or get another rod. goo dluck

jamie
 

·
Registered
Joined
·
298 Posts
I agree with MRPeal. That exact thing happened to me. I had worked on the engine while sitting on the front support and radiator. After that my hood would not latch!!!! When I closely inspected it, the locking mechanism was slightly bent.
 

·
Premium Member
Joined
·
1,272 Posts
on the 77 the u in the hood broke in the rear,, fixed it and the hood broke too... dont remember f or r ..look might be same thing
quinn
 

·
Premium Member
Joined
·
886 Posts
I have adjusted mine by loosening the 2 bolts on the latch where they are "snug" (resist movement, yet can be moved, if that makes sense) and closing the hood. That way, the latch will center on the bar. Open the hood and tighten down the latch bolts. Worked on my 79 and my 88. Good luck.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #6 ·
hey wod, check to make sure that the steel rod part on the hood isnt bent. that is somewhat common to see them bend a bit and then not fully seat in the primary latch. you can always double check the release cable isnt staying pulled too. this is common as well. has anything changed. accident, damage ect. if not look at the rod and make sure it isnt bent and if so try and straigten or get another rod. goo dluck

jamie
Thanks Guys, I think the rod may be bent. I am going to
replace it and see what happens. The latch mechanism looks
ok. I will let you know.

WOD
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top