Dodge RamCharger Central banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi there new to this forum and to dodge and ram chargers. I have a 1990 5.9 ramcharger. Went to start it up after work and it started idling really rough like it wanted to die, and it also started smelling like it was running really rich. Spent some time looking for loose connections and hoses didn’t see any. However when you shut the car off it would make a weird electrical almost grinding noise. Spent some time trying to find that. And pinpointed it coming from the iac motor. If this is malfunctioning would it cause it to run really rich to the point of having black smoke? Any help would be much appreciated
 

·
Registered
Joined
·
13,500 Posts
your truch has on board diagnostics , while it does not read in words , it gives "trouble codes" switch key ON/OFF ON/OFF 3 times 4th leave ON , watch dash lights they should flash out a number of times , it will repeat if done again ... the last should always be 5 flashes , a pause , and 5 more flashes  which is saying 55 or end of codes. post up the codes you get ... idle air motor BY ITS SELF it just moving the throttle stop , not changing air fuel mix ... 
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I did the key on/off several times no lights flashed. I just got this ramcharger and like it a lot I’m hoping this issue isn’t going to end up costing me a ton.
 

·
Registered
Joined
·
13,500 Posts
My apolagies , it may be 3 last On stays ... lemme try one of mine ... YES .. on/off on / off ON wait check light will go out wait it will then begin it flash codes . last one 5 short pause 5 ( end of codes) it should at least DO that meaning it looked and there are NO codes ... sorry for being off there ... try again ...
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Still no flashing lights, the only light that does turn on once and goes off right after I leave the key on is the maintenance required light I tried taking a video of the procedure to show but the file was too large
 

·
Registered
Joined
·
31,877 Posts
does the CEL even work [ Check Engine Light] at all / other wise you need the OLD Snap-On red brick [ 2500 scanner] to get codes and LIVE data out
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
So I’ve let it sit for a lil while, just started it up too see how it’d run, it was running fine, popped the hood cause I thought I could smell gas, and boy could I, it was pouring out from under the air filter
 

·
Registered
Joined
·
13,500 Posts
so a leak  from where ?
 

·
Registered
Joined
·
1,005 Posts
Magnus123 said:
Haven't pulled the air cleaner off yet, I'm hoping a hose or something popped off. Has anyone seen that before on these 360's
float needle valve is stuck open
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top