Dodge RamCharger Central banner
1 - 6 of 6 Posts

·
Registered
1977 W-200 318-727-203
Joined
·
417 Posts
Discussion Starter · #1 ·
busy doing a tune up, (installed other engine) and when Iwas checking everything I got sparks!!!!
I was touching the round piece on the cooler body from the electronic ignition box attached to the drivers side inside fender from my '77 W-200

I guess that's not really normal. anyone a clou about what could be the cause?
Thanks.
 

·
Registered
Joined
·
649 Posts
area51 said:
I was touching the round piece on the cooler body from the electronic ignition box attached to the drivers side inside fender
What? I have no idea what this is. Can you post a picture? It sounds like you might have a spark plug lead or coil lead that has cracked insulation or a torn boot, possibly a damaged coil tower.
 

·
Administrator
Joined
·
62,302 Posts
That sounds like the switching transistor. It can give a shock.

 

·
Registered
1977 W-200 318-727-203
Joined
·
417 Posts
Discussion Starter · #4 ·
exactly, I was busy making a pic. but you are faster!

does that mean I have to replace that part? or is that "normal"??
 

·
Administrator
Joined
·
62,302 Posts
Its normal.
 

·
Registered
Joined
·
232 Posts
My distributor shocks me from time to time when I'm adjusting timing...the boot on the coil wire is a little short.

It does not feel nice and I've taken to shutting the truck off, making a small adjustment and starting back up to check lol. Spooked me out of adjusting while running even after I fixed the coil wire.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top