Dodge RamCharger Central banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1,139 Posts
Discussion Starter · #1 ·
1988 rc... The only gauge that works is the battery, the oil, temp and 4 wheel drive indicator does not work. could it be fuses? The speedometer and horn works...the gas gauge doesn't!
 

·
Premium Member
Joined
·
4,879 Posts
Check the fuse.

If the fuse is OK, check & clean the bulkhead connector, and the connections at the back of the instrument cluster. If you get this far, remember to replace all of the gauge cluster lights. They are cheap.

-SM
 

·
Premium Member
Joined
·
17,219 Posts
geronimo said:
1988 rc... The only gauge that works is the battery, the oil, temp and 4 wheel drive indicator does not work. could it be fuses? The speedometer and horn works...the gas gauge doesn't!
first of all, you probably have to consider that it isnt a fuse. while these are gauges you also have to consider that each of the items you mentioned run off of a different sending unit, not a fuse, i would check to make sure that all of the sending units are connected under the hood, then check the bulkhead connections for being clean and then check to make sure thay are all tightened on the back of the gauge cluster.

the 4wd indicator light is ran by a pressure switch on the shift lever, it could either be dirty or unconnected.

as for the fuel gauge the most likely culprits are either loose connections or a bad sending unit

eric
 

·
Moderator
Joined
·
7,995 Posts
The 3 gauges get their voltage from a Voltage Limiter on the back of the instrument cluster and it looks like this.

Check all your connections on the back of the cluster. The 4x4 indicator bulb may be burned out, wiring problem or a bad switch.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top