Dodge RamCharger Central banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey folks,

Having some driveability issues with my '90 RC w/TBI. Haven't had this truck too long but here goes.

Bought from original owner with 82K mis. in good condition but noticed a dead spot in acceleration at the crucial range needed in city driving and getting around curves, i.e. a general lack of balls! Also, delayed throttle response. If I blip the throttle it'll come back to idle but then rev up like it should've when I first hit the throttle. I replaced the plugs, wires, tps and map sensor with no results (throwing parts at it!). Then checked codes and came up with #33, 37 and 42. Just for the hell of it, I replaced the flex fan the previous owner installed with an original fan from the junkyard. Strangely, this seems to have eliminated the #33 & 42 trouble codes. This slightly improved driveability and got rid of the giant fan going down the street sound. I have not disconnected the battery since I put the new fan on. Should I?

Has anyone else had any experience with this #37 code? The manual says part throttle cut off solenoid circuit open or grounded. Does this torque converter solenoid go bad?

Keep on keepin' on.

Justin
 

·
Premium Member
Joined
·
16,239 Posts
If you have a 4x4, then you have an A-518 tranny which has a non-lock up torque converter. Code 37 is basically a default code on our trucks, kinda like 12 and 55.

I spent a lot of time researching this. :p

(I have a 90 4x4 RC :) )

edit: I just looked up the actual wording in the fsm. It says, "An open or shorted condition detected in the torque converter part throttle unlock circuit (Engine packages with A-999 or A-500 automatic transmissions only". (emphasis mine)

Also, try some kind of injector cleaner. I used Lucas. It seemed to help a little bit.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Cooper,

Thanx for the reply. I thought no one ever would. I've got the 518 trans. but it's only a 2WD. I couldn't remember when I wrote my first message but the other parts I replaced were the TBI injectors. I also ran a few fill ups with some fuel dryer too after the injector replacement didn't work.

Would you figure the solenoid at the torque conv. to go bad?

My brother looked at it and drove it around and told me to put a cam and lifter set in it. This sounds a little far out to me. I don't see a worn cam causing my throttle response to be all delayed and then a rev up after returning to idle. Who knows?!

I really want to like this truck.

Justin
 
1 - 4 of 4 Posts
Top