Dodge RamCharger Central banner
1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Situation:
I have a 1991 W150 with a 318 and an A518 automatic. There are three problems that all seem to occur simultaneously. The speedometer needle won't work, the truck starts running ridiculously rich, and the transmission won't go into overdrive. All the problems seem to heal themselves when I put my foot down some. Does anyone have an answer or any advice? I've tested the speedometer itself, had the trans checked out and even had a new solenoid put in, and the engine is just a mystery. Everything checks out until you get on the road.
Thanks, Devan.
 

·
Registered
Joined
·
2,513 Posts
The speedometer & OD issue could be related. I'm not sure when the speedometer went electrical but when you disconnect those type the transmission won't go into OD. That was the case with my 95 Ram.

Is there any binding with your accelerator cable/linkage & the transmission kickdown?

Bucky
 

·
Registered
Joined
·
13,500 Posts
yeah , do the key on/off/on/off/on count the flashes .... pull codes , USE code FOR your year ( they differ some year to year ) check for a bad ground , back of engine , to firewall , 2 wires there , also , on rad support near battery ...
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
I use the term tested loosely. I have another speedometer that I know for a fact works so I plugged it into the dash but the truck continued to act up. I think it almost has to be a short but my father is convinced that the computer itself is going out. If it is a short I have no clue where to even start looking for it. Battery? Computer? Bulkhead connector? I also don't understand the correlation of why flooring it makes everything work.
 

·
Registered
Joined
·
13,500 Posts
test the fuel pressure ? 318 tb has a pressure regulator at the rear of the engine , that regulator has a vacume diaphram which when ruptured leaks / pours fuel into the vacume hose , which returns to the intake , if that is happening , the engine would run rich , throttle would increase the AIR and slightly decrease the fuel mix if the o 2 sensor works and has cut back the injectors time open .  speedo ? not related to rich too old of a system for that .. short ? speedo failure , 518 ? look , check harness from speedo sensor AND 518's vertical 3 wire plug for O.D. runs up on top of trans ...... shorted O.D. solenoid can cause meltdown of harness , short the speedo as well ... ? can may possiable did NOT say oh yeah it's this .... said check ... ;) 
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
dodge82273 said:
test the fuel pressure ? 318 tb has a pressure regulator at the rear of the engine , that regulator has a vacume diaphram which when ruptured leaks / pours fuel into the vacume hose , which returns to the intake , if that is happening , the engine would run rich , throttle would increase the AIR and slightly decrease the fuel mix if the o 2 sensor works and has cut back the injectors time open . speedo ? not related to rich too old of a system for that .. short ? speedo failure , 518 ? look , check harness from speedo sensor AND 518's vertical 3 wire plug for O.D. runs up on top of trans ...... shorted O.D. solenoid can cause meltdown of harness , short the speedo as well ... ? can may possiable did NOT say oh yeah it's this .... said check ... ;)
Not to shoot you down but again, all the problems go away when I floor it. All at once. The three almost have to be caused by the same problem.
 

·
Registered
Joined
·
13,500 Posts
flooring it , many of the inputs from sensors are "ignored" by the pcm , and it runs on presets  , so what is the one common factor / wire that is shorted ? a wire diagram could help ,oh , yeah flooring it shuts off the grounds for O.D. and lock up solenoids , and the o2 sensors , 2 less grounds sent thru the harness for them that the speedo is also bundled in ,ground goes away , short goes away ?? like I said check that harness ..  and then sometimes dads are right .
 

·
Registered
Joined
·
31,877 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #10 ·
I'm gonna test the TPS and check my grounds. Found a bad plug wire yesterday, plan on replacing it. I have wiring diagrams for the truck and have found which pins run the afflicted areas. Hopefully one of these will give me a solution.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top