Dodge RamCharger Central banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5,581 Posts
Discussion Starter · #1 ·
86 Ram Van, 318. went to crank it one day, wouldnt crank. jumped it, and while driving down the road the lights kept gettin dimmer and dimmer. came home, shut the van off, wouldnt restart. took out alternator, had it tested, tested fine. put it back in, replaced battery. drove it, same thing. replaced voltage regulator with one off another truck, it would charge the battery as long as i didnt run any accesories. turn on lights/fan/radio, charge wouldnt get to the battery. replaced it with new v/r, same thing. what is going on? what else can i check?

Duane
 

·
Registered
Joined
·
1,764 Posts
Recheck all the connections. Did you check the output at the battery and the alt? Could be a bad wire. If you can make it to an Auto Zone or something, they can put it on a tester and narrow it down if you don't have the stuff to do it..Since you can jump it, I would guess it to be between the alt and battery.




EZ
 

·
Moderator
Joined
·
7,995 Posts
Just a thought...one of the things I am finding with these turkeys that test alternators is if they see voltage they think its ok! You can have correct voltage but not the correct amperage output. I'm sure you checked for a good ground at the VR?
 

·
Registered
Joined
·
5,581 Posts
Discussion Starter · #4 ·
yes i did chump, but once it quits snowing im going to recheck it. can i test the alt for the right amps myself?

Duane
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top