Dodge RamCharger Central banner
1 - 7 of 7 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
I recently built a 360 for my 86' W250. It's an 84' block bored .030 over. I'm not sure about compression, I used a rebuild kit from mancini. She's got swirl port cast #308 heads off an 89' with adjustable rockers. Cam is a crane 204/216 @.050 .427/.454" lift. Topped off with an edelbrock performer intake with a performer 600 cfm #1405 carb. The distributor has the spring kit from Mopar with only one light spring installed and one stock spring. Here's the trouble, the @#$
thing is making less power than my 6yl did. She puffs smoke when you shift and at start up. Also when you hit into the 4brl the truck just falls flat on its face. I contacted edelbrock and they're telling me to put 14 degrees of initial advance into the cam. The motor only has about 1500 miles on it. Any input?
 

·
Premium Member
Joined
·
17,219 Posts
did you degree the cam or just put it in and line up the dots?

also, the smoke when you shift sounds like you might have the carb set a bit rich.

what is your timing set at right now?

from the items you have placed on there and that cam you should have alot more power than what you are describing, i ran into the same problem when i swapped cams and my numbers arent to much different than yours(209/220 @50 and 429/444), i am in the process of degreeing the cam now when i get the degree kit.

also, do you have all of the vacuum stuff hooked up, positive there are no vacuum leaks?

eric
 

·
Registered
Joined
·
97 Posts
Discussion Starter · #4 ·
The smoke i'm talking about is white, I'm beginning to think that my rings never seated. As for the cam I just lined up the dots.
 
1 - 7 of 7 Posts
Top