Dodge RamCharger Central banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
'92 ramcharger canyon sport stalls when engine gets hot/under stress, also suddenly loses speed under highway conditions briefly before re-engaging again when engine is hot. Once stalled - it'll turn but won't restart until engine cools. Also when starting in the morning, ignition doen't even turn over until I press the gas pedal. Had fuel filter replaced, accelarator relay replaced. had the dodge dealer run the truck all day and it failed only once but no computer codes, but they want to revamp the transmission for $1900. Took it to good transmission specialists, they said the transmission is fine. another dealer thought the wiring harness needs replacing. Any ideas how o proceed?

 

·
Registered
Joined
·
0 Posts
Sounds like you have a vapor lock problem. When the motor gets hot, it boils the fuel in the line so that it is just vapor. That is before it gets to the fuel rails for injection. When the vapors get there, the power goes down.

Another thing: When you say "Suddenly loses speed" are you meaning that it feels like the engine just suddenly shuts off? If that is the case, then it sounds like it could possibly be a bad distributor pickup. I just had this problem with mine, but went the fuel pump replacement route first. The distributor pickup is a cheaper fix, only about $45. I'd check on it first. This is commonly referred to as a "Hall Effect Sensor."


Randall
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Randal thanks for the fast reply. What do I need to check to fix a vapor lock problem haven't come across this before.

The sudden loss of speed usually it cuts out and stalls, ocasionally lose 30 mph and it'll pick up again, but mostly its a stall. almost did the fuel pump route, and was wondering about the hall effect sensor. I'll give that try first thanks

 

·
Registered
Joined
·
25 Posts
somuchtodo said:
Randal thanks for the fast reply. What do I need to check to fix a vapor lock problem haven't come across this before.

The sudden loss of speed usually it cuts out and stalls, ocasionally lose 30 mph and it'll pick up again, but mostly its a stall. almost did the fuel pump route, and was wondering about the hall effect sensor. I'll give that try first thanks
Hi the coil could cause these problems too .. Real cheap fix
 

·
Registered
Joined
·
0 Posts
somuchtodo said:
The sudden loss of speed usually it cuts out and stalls, ocasionally lose 30 mph and it'll pick up again, but mostly its a stall. almost did the fuel pump route, and was wondering about the hall effect sensor. I'll give that try first thanks
Since it is just like a stall, check that hall effect quick, before it leaves you on the side of the road. Mine was cutting out like you said, then it started to just die. After sitting for a little while it would start again, but the sitting times usually kept getting longer and longer, with the running time being shorter and shorter, till it started no more :( Got it fixed though, and not a prob since ;D

Randall
 
1 - 5 of 5 Posts
Top