Dodge RamCharger Central banner
1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey guys new to forum all help is appreciated. I just bought my old 89 ramchanrger with the 360ci back and it starts when you hit the key runds great for 3 seconds and turs iff like you hit the key any ideas it has spark and fuel beacause it starts everytime just wont stay running i can keep it alive if i hold the throtgle down but as soon as i let off it dies
 

·
Super Moderator
Joined
·
14,344 Posts
check codes - key off/on 3 times without starting it
 

·
Registered
Joined
·
13,500 Posts
yes check for codes , check fuel residual pressure after stalling  , fuel pump relay  asd relay  ,  pick up in dizzy under rotor .. ? some guesses .....
 

·
Super Moderator
Joined
·
14,344 Posts
What is the actual code number?
 

·
Registered
Joined
·
13,500 Posts
fresh bat ?   
 

·
Super Moderator
Joined
·
14,344 Posts
TPS could alter your idle speeds. Not sure it would make you stall out. It could. You'll have to test it. One wire is 5 volts, one ground, and the center should vary from 0 to 3 volts as the position is moved.

I'd also look at the idle control motor. Those fail and don't give a code. The gear inside can strip. There's a procedure to set the correct idle:

 

Attachments

·
Registered
Joined
·
13,500 Posts
both injectors operate together , so not fuel filter as that is for both , bad wire to one injector , bad connector at injector , outside chance low fuel pressure and a weak return spring on the injector that DOES fire . asked about battery because disconnecting it clears codes , code will not reset untill engine warms up and runs long enough , so new bat means stored codes lost ... runs only 3 seconds , will not reset codes . it should continue to run , at least poorly, on 1 injector , check fuel pressure . 
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #13 ·
Ok thanks again for replys... here is what i tried tonight i swapped plugs on injectors no change still only driver side was pushing fuel out in a nice v shaped pattern. Second i tried switching the injectors and STILL only driver side was fueling but this time it was spitting a bunch of fuel enough so that the truck would stay running. Then i was thinking it waasnt getting power to the passenger side so i put a multimeter on it and saw that it was but i still tried putting staright battery + and - to it still nothing. Last thing i tried was unpluging just the injector that was working to see if maybe it would bypass that one and fuel the passenger side but driver side was still dripping and spitting not as much as before but was still trying to run even with it unpluged. ???? Need help please
 

·
Registered
Joined
·
13,500 Posts
clogged fuel galley TO that injector ,or  low fuel pressure .
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top