Dodge RamCharger Central banner
1 - 4 of 4 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
I have an 89 that died while driving and would not restart. Noticed a 20ga. white fusible link was getting hot enough to melt insulation. Got rained out before I could do much snooping, truck is 40 miles away so I'm attempting to get boned up on troubleshooting fusible links and such before heading back tomorrow.
Engine will turn over but not start - the fusible link gets hot within a few seconds. Truck has 200+K, I have had truck about a year with no prior major electrical issues. I suspect the fuel pump may have a short, did not get a chance to check for fuel flow during start attempt due to the monsoon that set in.
The fusible link appears to be between a large gauge red wire going to the SMEC and what I think is the  ASD relay (black relay next to the starter relay). Wondering if anyone has had similar issue.

Thanks
 

·
Registered
Joined
·
227 Posts
Sure did couple of years ago.  Replaced all of them with bus bar assembly

 

·
Registered
Joined
·
104 Posts
check your rotor while you are there. had a no start prob a while back and found out the tab on top of the rotor was busted off. take a fresh rotor with you. they are only a few bucks.
 

·
Registered
Joined
·
29,359 Posts
well the ASD relay powers the -coil-injectors-02 sensors-PCM-and the fuel pump relay / so if its getting hot you can have a short anywere in one of those things

email me for the wiring diagram
 
1 - 4 of 4 Posts
Top