Dodge RamCharger Central banner
1 - 15 of 15 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
My Speedo has been jumping +- 5 mph randomly and the cruise control is a PIA to get working (if at all).
I pulled the speed cable from the tail shaft to the cruise control module today and located the problem within the cable. Any help finding the correct cable? It’s about 68”-70” long and has the typical square rod on the inside. The original cable has a female (receiver) portion which connects to the tail shaft, and a male square rod tip which connects to the cruise control module.

Both utilize a threaded female fitting. I will attempt to upload a picture here.

Incase I haven’t added info: 88 w250, 4x4, auto a727, 360 4bbl. Gramps old truck-My daily driver
 

Attachments

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
The ones at NAPA all have the male square rod that’s protruding out both ends. I’m unsure if it’s needing to be a custom job or what.
 

·
Super Moderator
Joined
·
14,339 Posts
jakesclark08 said:
The ones at NAPA all have the male square rod that's protruding out both ends. I'm unsure if it's needing to be a custom job or what.
That's what it's supposed to be. The square rod is what gets turned. The rest is just the covering cable and attachment nut.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #6 ·
So I’ve done some digging, and this is what I’ve uncovered:

Dodge dealer says the 68” cable (#4897547aa) has been discontinued since 2017.
Also the cable needed is for a 241 t case which has specific end connectors and squat rod (male and female).
To be specific the cable needed is for the case tail housing to the cruise control module. NOT  straight to the speedometer. (Needing a metal,threaded fastener and square rod receiving hole.

Any ideas now? If you note the picture of the threaded fitting, one has a protruding square rod and the other does not. This is what I’m looking for. I’m sorry if I sound ignorant, I’ve tried many house researching and returning other cables...
 

·
Super Moderator
Joined
·
14,339 Posts
jakesclark08 said:
So I've done some digging, and this is what I've uncovered:

Dodge dealer says the 68" cable (#4897547aa) has been discontinued since 2017.
Also the cable needed is for a 241 t case which has specific end connectors and squat rod (male and female).
To be specific the cable needed is for the case tail housing to the cruise control module. NOT straight to the speedometer. (Needing a metal,threaded fastener and square rod receiving hole.

Any ideas now? If you note the picture of the threaded fitting, one has a protruding square rod and the other does not. This is what I'm looking for. I'm sorry if I sound ignorant, I've tried many house researching and returning other cables...
If you push the male end, does it not come out that female-end? That's how I remember my cable being but I might be mistaken. Are you saying one of your components, T case or cruise module, has a male protrusion? I don't recall that being the case.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #8 ·
I’m sorry if I’m not articulate. But the cable itself has a male protruding in one end and a female (to receive a male) protruding on the other. The female side connects to the t case, the male connects to the cruise control module. I’ll snap a pic here in a bit.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 ·
Okay, so had more time this evening to tinker. I realized how ignorant I was to this part. The male portion which protrudes out of the cable and into the tcase , was broken off and sticking out of the t case. Appearing like it’s a opposite male/female meet up. I apologize.

However I found a cj-7 Jeep speedo cable which fits perfectly (length and threads). Buttttt, I installed it today and wa-la! Super clear and steady speedometer. After driving 55mph for 1/2 mile something happened and it broke my cruise control module gear and broke the pin off the speedometer gauge as well. 😭😡

Now I’m in the process of finding a new cruise control module, if anyone knows.
 

·
Super Moderator
Joined
·
14,339 Posts
that's what we were trying to tell you lol. I suspect you had a seized cruise module to start with, and the cable broke because of it.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #12 ·
I have successfully found a cable which fits but a gear in the cruise control module broke during operation. I’m not sure what to do now... Just 1 gear. These truck are fun and easy but require a lot of research for parts! 🤦🏼‍♂️
 

·
Super Moderator
Joined
·
14,339 Posts
jakesclark08 said:
I have successfully found a cable which fits but a gear in the cruise control module broke during operation. I'm not sure what to do now... Just 1 gear. These truck are fun and easy but require a lot of research for parts! 🤦🏼‍♂
You can get a standard length cable for a truck without cruise control and attach it straight to the speedometer until you can find a working cruise module
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #14 ·
Awesome thanks for y’all help. That’s what I’ll try.

As stated before. A cable for a cj Jeep worked. A little short. But worked. After putting all together it produced speed for a little bit then stopped. After diagnosing the problem, the new cable broke at the same spot. The square rod which connects to the t-case. Maybe another underlying issue?
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top