Dodge RamCharger Central banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5,081 Posts
Discussion Starter · #1 ·
I've been trying for about 3 hours to get my Ramcharger to start & all I get is a click when I try to start it.
It's been sitting for about 4 months. I had to change transmissions, that's why I had it parked for so long. It ran fine before-hand.
I cleaned the battery terminals & slapped the load tester on the battery; turned out ok. I only had the - terminal off the battery the whole time the truck was down.
Also checked the neutral safety plug on the trans; it's ok.
I did take the starter out to see if it would engage (key on), but I don't even think there's power that "far".
There's 3 relays on the firewall too, I checked those, & can only get Codes 11, 12, 55 out of it, which tells me the battery was disconnected (duh)... ::)
The truck is an '88 RC 4x4, 318 TBI, 727
I don't know what's going on with it & it's pissing me off.....
 

·
Registered
Joined
·
5,081 Posts
Discussion Starter · #2 ·
Forgot to mention this thing has a Ford alarm on it also (gotta love previous owners....) that may be causing some of the headache? If I knew how to get the hell rid of it, I would.
 

·
Registered
Joined
·
3,489 Posts
usualy to get ird of an alarm find the brain rip it out end of alarm. You may also need to do some wire splicing to take the starter kill out. (Some ripping the brain out is enough some you have to repair the harness where the alarm hooks into the start circut)
 

·
Registered
Joined
·
5,081 Posts
Discussion Starter · #4 ·
I tried before to just unplug it (it's under the dash) & doing that = no start...
Wonder if I'm experiencing starter kill right now....hmmmm
Thanks!
 

·
Registered
Joined
·
5,081 Posts
Discussion Starter · #5 ·
It runs now....starter turned out to be junk;
 
1 - 5 of 5 Posts
Top