Dodge RamCharger Central banner
1 - 7 of 7 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
hi this is my 1st post so please bear with me
i have a 1975 dodge ramcharger the truck used to
have a 360 but i got it with a 318 so now the engine
is rebuilt but i have several problem (they existed befor it
was removed)
1st is the motor mounts what bracket should go on what
side one has 3 bolts and is cut at an angle one has 4
and is u shaped?

2nd my timing chain cover has no timing marks or rasied boss on it at all
any ideas i will not be able to time it ?
is there a tab i can get?

3rd my front lower pulley bolt holes dont line up
i can get all bolts in except 1

4th i could use a picture of the alt. mounting brackets
mine was way wrong when i removed it and i would
like to put it back on correctly

i am sure i will have more questions
later

thank you for all your help

bob
 

·
Registered
Joined
·
12,472 Posts
Seems like the acesory pullies are from a newer SB like from an 80's model possibly . AS ofr the pics Chump can get u the pics of what the pulley set up is . U can get a haynes manual and it iwll show it in there as well .
As ofr the timing marks u can get some timing tape and u have to get it # TDC then stick it on the cover housing . I guess sombody used some butchering on the engine mounts . I would go find some originals from a bone yrad clunker and use those with new rubber isolators .
 

·
Premium Member
Joined
·
5,548 Posts
#1 The motor mount brackets go on the rear side of the ears on the drivers side and on the front side of the ears on the passenger side. 318's and 360's have different left side motor mounts i believe.

#2 71 and earlier small blocks had the timing tabs cast into the timing cover but on the passenger side. Not the drivers side like 72 up. So look down in the fuel pump area for it.

#3 Also before 72 they had a different damper on the engines that had one offset hole. This can be corrected with a round file. This is a normal and recommended fix by Mopar.

#4 can't help ya there.

I bet your engine has the lower water pump hose on the drivers side. 72 and later small blocks have them on the passengers side. If you ever want to change that then you need to change timing cover, water pump and damper.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #4 ·
thank you i have the haynes book but it did nt show it so
i could still use a photo!

my timing chain cover has no marks at all raised or oher wise

water pump out let is on the pass side

motor mount bracket looks like it came the way it did

thank you
please add any more if you can
 

·
Premium Member
Joined
·
5,548 Posts
Ok you have a 72 up timing cover and water pump then with a 71 down damper. Your timing marks won't line up. The timing marks for 72 up is on the drivers side. All small blocks have the marks cast into the timing cover. I doubt anyone ground them off.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #6 ·
no markings at all on my timing chain cover
none where ground off either. just nothing smooth
all over any ideas ?
i was told the motot home engine cover did not have marks
because you timed it at the bellhousing and i wonder if this is my cover although my block says 1968 and 318-1
my machinest told me i have a -3 crank and rods!
 

·
Premium Member
Joined
·
5,548 Posts
well i have plenty of front covers i would part with if you would want one. Thier all for 1972 and up though.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top