Dodge RamCharger Central banner
1 - 4 of 4 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Hi all,
I just put a rebuilt 360 into my 84 ramcharger and it is running but not smoothly. I have the timing set to 14* btdc, alltho the distributor seems to be turned much more than the other motor. The vacum advance port is almost facing straight foward, is that normal.

There is an aditional problem that may or may not be related. The valves are making ALOT of noise, one suggestion was that the lifters arn't filling up for some reason.

Anyway the symtoms:

Running fairly good at idle timing at 14
trans in gear engine stumbles a little
any amount of acceleration there is noticable misfiring and ruff running, power still seems to be lacking from the 318 in my old PW.

Any suggestions?

I think I am going to start by individualy checking for spark on all cylinders.

some of the new setup includes

new plugs
new distributor
new wires
new msd coil
new carb
new intake
new cat and flowmaster catback
 

·
Registered
Joined
·
619 Posts
check your plug wires. sometimes if one has a bit of a tighter stretch from the distrubotor to the plug, it can get loose and start to misfire. its happened to me before. try pushing down and snugging them up. if that doesn't work then pull it all the way off and then put it back on.
 

·
Registered
Joined
·
30,059 Posts
it sounds like yer off on yer number 1 cyl / turn the DIST back to were you think it should be / then refind TDC and rewire yer plug wires / that and start off with 8 to 10 BTDC timing till you get it running right
 

·
Registered
Joined
·
1,550 Posts
Could be a notch off on the distributor when you sit it down in? I have done it and the distributor was sitting in a different spot once timing was set.
 
1 - 4 of 4 Posts
Top