Dodge RamCharger Central banner
21 - 35 of 35 Posts

·
Registered
Joined
·
31,917 Posts
after that it is above my pay grade, will have to send it out for repair.
l,m a 47 yr ASE master mechanic that "specialized in automotive electronic diagnostic repair" and it's also above my pay grade [ i could do it if l had my hands on the manuals ]
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #22 ·
Hello,
Just my luck swapped out both speedometer heads in my cluster, did not work, so put the original heads in their original cluster, did not work, I would have hoped one of the combos would work.
So I have three clusters and not one speedometer worked? I think I will replace the servo at the transfer case. After that Phone GPS.
 

·
Administrator
Joined
·
31,525 Posts
Look at those 3 black cylinder parts. At the top where they have the cross scored into the metal, generally if they go bad they will start to bulge there. The score is so the top blows, instead of the sides. They are the most likely parts to go bad. After that would be the stepper motor.



But, since you tried several different combinations, I would look at the sensor at the transfer. then the connections up through.

Second thought, since both the speedo, and the odometers are not working (you did not mention one working), I would even more look at the tranny end.

Simple, make sure the adapter that holds the gear is clocked right. Shine a light into the transfer, to see how the gear inside looks. If it is a three wires sensor, one of those wires from the computer should have voltage when the key is on, most likely 5 volts.
 

·
Registered
Joined
·
31,917 Posts
l need to know if you have a 2 or 3 wire VSS [ vehicle speed sensor ] to post the wiring diagram
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #25 ·
Ok bought a new speed sensor, checked that I do have 5.43 DC with meter so that it does have power form the ECM, installed the new sensor still nothing, put a jack under rear and put in Drive nothing, with new sensor, but pulled the sensor turned the key on I turned by hand and wife watched cluster the trip meter moved so the odometer is working, something is wrong with the gear?
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #27 ·
Installed the cluster with 238,000 miles, got under the Ramcharger spun the VVS got both odometer and speedometer with key on, swapped out the working little motor off the one that is working and put it on my speedometer that only had odometer, will run by hand tomorrow night, if it works then pull the gear out of the transfer case to see why it is not turning the VVS.
 

·
Registered
Joined
·
31,917 Posts
also you gotta make sure it's clocked right , the speedo housing can go in 4 different ways but only 1 is correct

you can look right in at the gear with the speedo housing out
 

·
Registered
Joined
·
31,917 Posts
also you gotta make sure it's clocked right , the speedo housing can go in 4 different ways but only 1 is correct

you can look right in at the gear with the speedo housing out
yup
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #34 ·
OK got it fixed, swapped out the board from parts speedometer that was good to my speedometer, then checked the gear, I did not put it back in correct I guess, replaced the speed sensor which I guess was bad, test drive on jacks it all works now, Thanks to all who helped me with finding out what was wrong.
 
21 - 35 of 35 Posts
Top