Dodge RamCharger Central banner
1 - 10 of 10 Posts

·
Premium Member
Joined
·
1,154 Posts
Discussion Starter · #1 ·
Was running fine then started spitting and sputtering under exceleration I first thought fuel filter dropped tank changed filter washed out tank repaired crack I found put it all back together still doing same thing ran codes got 33 34 21 37 64 65.  Any ideas..
 

·
Registered
Joined
·
31,877 Posts
the 21 an 64 would be yer problem , the 21 oxygen sensor making the motor run all funky and clogged the 64 convertor / this was a common problem back in the day [ early mid 90,s ] have someone rev the motor up whiile you listen at the tail pipe , if it sounds like its a stuffed up hoover vacuum , then its clogged
 

·
Premium Member
Joined
·
1,154 Posts
Discussion Starter · #3 ·
Thank you just went out side took a look under it and there is no cats or o2 sensors so that explains the codes any other ideas why it was running fine then started to sputter..  also ran it down the highway if I stomp it to the floor it will run out just fine 70 plus then 3rd gear lowed rpms back to sputtering and falling on face
 

·
Registered
Joined
·
31,877 Posts
well there is most definitely an oxygen sensor on it , the truck would not run at all without one , its in the left manifold on the inside towards the block faciing forwards , your truck has whats called "mini" cats in the Y-pipe  and then it should have a large one on the side of the t-case

if it aint that then l,d go after the fuel pressure
 

·
Registered
Joined
·
13,500 Posts
most fellas are use to seeing the o2 sensor somewhere in the pipes , your truck needs one unless you have a carb on it now . It was in the cast iron exhaust manifold ,  near the cylinder head ....
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top