Dodge RamCharger Central banner
1 - 9 of 9 Posts

· Registered
1974? w-200 440/dana 60 swaped on 35s
Joined
·
60 Posts
Discussion Starter · #1 ·
i bought i 87 or 89 d250 with cummins in it and the turn signals and brake lights have worked for a couple months. just randomly the back ones went out. the rear bulbs work for the runing lights but not the signals or break lights. the front ones still work. they are aftermarket led ones though. y'all got any ideas on what could be wrong.
 

· Administrator
Joined
·
31,939 Posts
Check the 4 way flashers. If they work, then the issue is likely in the turn signal switch itself. But a lot of times it is the 4 way flasher switch not getting reset right (push or pulled, depending on the year)
 
  • Like
Reactions: snowfighter10

· Registered
1986 Ramcharger 4x4 318 auto. 4" lift 35" tires
Joined
·
9 Posts
i bought i 87 or 89 d250 with cummins in it and the turn signals and brake lights have worked for a couple months. just randomly the back ones went out. the rear bulbs work for the runing lights but not the signals or break lights. the front ones still work. they are aftermarket led ones though. y'all got any ideas on what could be wrong.
Hello how are you? Just a thought, had the same problem with my 86 ramcharger and I found rotted wires at the rear lower body wire connector, driver's side, before it feeds up to the tail light. Had the same issue with the fuel gage not working properly. I'm in the process of a rewire of the 12' section of wire harness from front to the rear. I'm also updating the wire gage size to a little larger gage. Something to check off your troubleshooting list.
 

· Registered
1974? w-200 440/dana 60 swaped on 35s
Joined
·
60 Posts
Discussion Starter · #6 ·
update when the hazards or 4 way is on only FRONT 2 blink and at the right speed. when i have it signaling left only the front works and it blinks at the right speed, and when it's signaling right only the front works too but it doesn't blink consistently or as fast as the others. i'm thinking it might the the turn signal assembly that's on the shifter.
 

· Administrator
Joined
·
31,939 Posts
The switch is a good candidate. But first look at the wires along the frame going back, and across the back to the tail lights. Also try a regular bulb to see if that makes a difference.
 

· Registered
Joined
·
8 Posts
If I was home and near my data base i.d post the wiring diagram. But off the top of my head i.d day check all grounds and see if you have any trailer hitch wiring plugs( most common rear lighting malfunction) with a diagram you could check power in and out of the blinker switch
 

· Registered
Joined
·
45 Posts
If both sides went out at the same time I'd put money on the turn signal switch. If you get a replacement you won't even have to tare the steering wheel apart to test it, just plug the new one in on the column to check.
If that doesn't do it next up would be check at the bulk head connection and all other connectors. Further down the list would be the brake switch itself, but I'd really doubt that a fault there would make that problem.
 
1 - 9 of 9 Posts
Top