Dodge RamCharger Central banner
1 - 20 of 22 Posts

·
Registered
Joined
·
438 Posts
Discussion Starter · #1 ·
4 speed auto in my 02 Dakota r/t.

Needs governor pressure solenoid. Never touched a trans before & was wondering if someone could put some part numbers/diagrams/or tips for the 46RE. Figured I’d ask before I’m on my back in the cold tomorrow.

How many quarts of fluid does it take? Anyone running Castrol fluid? I prefer Castrol products.
 

·
Registered
Joined
·
1,056 Posts
Not too bad of a job, drop the pan and its 4 bolts and two torx head screws to get the governor block down, then take off the snap ring and the sensor pulls out. I dont have any diagrams but Im sure DB will chime in with some. Id buy 5 quarts, start by adding 4 and then check it. I always use Castrol ATF+4 never an issue.
 
  • Like
Reactions: Lzed

·
Registered
Joined
·
29,712 Posts
yup pretty easy as long as the gasket does not screw up [ you can only get the gasket in a rebuild kit [ or beg at your tranny shop ]

 
  • Like
Reactions: Lzed

·
Registered
Joined
·
438 Posts
Discussion Starter · #5 ·
Part never showed up today like it was supposed to but instead I changed the engine oil and filter (partsmaster filter??). I’ll be picking up some Castrol fluid.

might try to get this done tomorrow if the parts show up and the weather isn’t too cold. Stay tuned, I have horrible luck.
 

·
Registered
Joined
·
438 Posts
Discussion Starter · #6 ·
Shoe Red Font Personal protective equipment Auto part


on the right is the old and bad solenoid, new is on left, accidentally broke the new which didn’t fit the exact same as the old (don’t ask me how). The old one is significantly bigger in size. Truck does has a shift kit. Anyone know where I can find an identical part to the old one? Or NOS?
 

·
Registered
Joined
·
438 Posts
Discussion Starter · #8 ·
Gotcha, I ordered another, one made in USA and I’m returning the fragile Chinese one. Hopefully it’ll be here tomorrow. Fluid didn’t look great coming out of the pan but there wasn’t any metal.

Automotive tire Motor vehicle Hood Automotive lighting Tire
 

·
Registered
Joined
·
438 Posts
Discussion Starter · #10 ·
it looks to have either water or some other kinda fluid mixed in
that’s what I’m afraid of. It didn’t smell too great either. Between running down my arms and in my hair it was nasty.

the code I have is p0748 and the part to HOPEFULLY fix that looks like it’s coming tomorrow from New York. I’ll post another update once the parts in and the pans back on.
 

·
Registered
Joined
·
438 Posts
Discussion Starter · #12 ·
Cleared the CEL, fired her up, checked the tranny fluid in neutral, need 1 more quart (using STP’s ATF+4 since that’s all I could find besides FRAM). Not leaking from the pan/around the gasket. Going to do a early morning test drive since the tags are expired to see how she’s shifting now. Hopefully she’s good.

ps. Forgot I got a little tranny fluid when taking the pan off on the exhaust and almost freaked out when I seen smoke coming up from under the engine.
 

·
Registered
Joined
·
29,712 Posts
in the days of "covid" the expired tags mean NO THING , here in my state the "vehicle registry" is closed , so it's basically the wild west as far as vehicles go , you should check your state "vehicle registry' wed site to see what their covid rules are
 

·
Registered
Joined
·
438 Posts
Discussion Starter · #14 ·
Took it out, shifted fine up and down the road. Let it cool off and it didn’t go into 3rd. Found a bad ground to the computer that broke right off and is corroded so I’ll fix that. If that doesn’t fix it I’m stuck.

Wheel Tire Hood Automotive tire Motor vehicle
 

·
Registered
Joined
·
438 Posts
Discussion Starter · #15 ·
If anyone has experienced this issue I’m having, chime in. I’m starting to think it might be electrical. will be putting a new ground in tomorrow. Apparently there is a fuse as well in relation to the transmission. should I use my test light and check the transmission wire in the harness to see if there’s power? I suck at electrical, only know how to cut, patch, see if there’s power with a test light.
 

·
Registered
Joined
·
438 Posts
Discussion Starter · #18 ·
Replaced two corroded grounds from the pcm wiring and switched the trans relay with the wiper relay to make sure that wasn’t bad, no luck.

it’s like every time I unhook the battery, the truck is good for ten miles then after that, it hangs in second gear. might test the continuity of the pcm and make sure the right wires have power tomorrow. sucks doing this in the cold with no lights or heat lol.
 
1 - 20 of 22 Posts
Top